Metadata could not be loaded

May 23, 2008 at 4:58 PM
hi I have built the solution and enter all the correct details but when the program tries to get the metadata i get the following error:

Metadata could not be loaded for the following reason.
"Object reference not set to an instance of an object."

can you help please?

Regards

Ian
Developer
Jun 15, 2008 at 11:50 AM

Hi Ian,

       I really appologize for being late in response. But please check if the user, you are using to run the tool has at least system customizer privileges (User should have prvileges equivalent to Out of box Role 'System Cuztomizer'). As user has to have at least those privileges to load metadata. Let me know if it does not solve your problem.


rango316 wrote:
hi I have built the solution and enter all the correct details but when the program tries to get the metadata i get the following error:

Metadata could not be loaded for the following reason.
"Object reference not set to an instance of an object."

can you help please?

Regards

Ian



Jul 30, 2009 at 11:08 AM

Hi!

 

I have the same problem. User has role System Customizer and System administrator.

 

Best regards,

stereo_sl

Nov 9, 2009 at 10:36 PM

Hi everyone,

 

We had the same problem and we solved it by installing MCRM on Windows Server 2003 and not running any of the rollups.

 

We had the problems when running MSCRM Map Editor on Windows Server 2008 with CRM updated to rollup 6. This solved our problems.

 

I don't think the rollups were causing the problem as this is an interface that is supported by Microsoft, I do think the problem was with Server 2008. However I thought I should mention both to help anyone else who is having this problem.

 

Thanks!

Jul 12, 2010 at 11:50 AM

Hi,

I have the same problem here. MSCRM is installed on Windows Server 2003 and i have SysAdministrator and SysCustomizer roles.

Does anyone have solution?

Thanks!